Thursday, April 28, 2022

Sum of Digits of a Five Digit Number

 Objective

The modulo operator, %, returns the remainder of a division. For example, 4 % 3 = 1 and 12 % 10 = 2. The ordinary division operator, /, returns a truncated integer value when performed on integers. For example, 5 / 3 = 1. To get the last digit of a number in base 10, use  as the modulo divisor.

Task

Given a five digit integer, print the sum of its digits.

Input Format

The input contains a single five digit number, .

Constraints

Output Format

Print the sum of the digits of the five-digit number.

Sample Input 0

10564

Sample Output 0

16

SOLUTION


#include <stdio.h>

int main() {
    
    int n,rem,sum=0;
    scanf("%d", &n);
    while(n>0)
    {
        rem=n%10;
        sum=sum+rem;
        n=n/10;
    }
    printf("%d\n",sum);
    return 0;
}

No comments:

Post a Comment

Featured Post

14. Longest Common Prefix

Popular Posts